Setup NFS on installation server to share DVD contents:
share -F nfs -o ro,anon=0 /export/home/Solaris10
[ssybl2:~]# cat /etc/dfs/dfstab
# Place share(1M) commands here for automatic execution
# on entering init state 3.
#
# Issue the command 'svcadm enable network/nfs/server' to
# run the NFS daemon processes and the share commands, after adding
# the very first entry to this file.
#
# share [-F fstype] [ -o options] [-d "
# .e.g,
# share -F nfs -o rw=engineering -d "home dirs" /export/home2
share -F nfs -o ro,anon=0 /export/home/install/Solaris_10/Tools/Boot
To re-read dfstab :
exportfs -a
Mount remote server’s installation NFS share point
mount -F nfs servidor:/mnt /export/home/solaris10ISO
#### installer ####
prodreg – application to manage add/remove programs on Solaris BOX
### Shell – Based package management tools ###
pkginfo – display software package information
pkgadd – transfer software packages to the system
pkgrm – remove a package from the system
pkgchk – check package installation accuracy
1. pkginfo – dumps to STDOUT (screen/terminal) all installed pakacges
pkginfo returns – category, package name, description
2. pkginfo -l [package_name] – detailed package listing
3. pkginfo -x returns and extracted list of packages. abbreviation, name, arch.
4. pkginfo -q queries for a package and returns exit status ( 0 / 1 )
5. pkginfo -i – fully installed packages
pkginfo -p partially installed
### pkgchk ### integrity
1. pkgchk -v SUNWevolution – checks/lists files included with SUNWevolution
2. pkgchk -lp – determines which package vim belongs to
# pkgchk -lp /opt/csw/bin/vim
Pathname: /opt/csw/bin/vim
Type: regular file
Expected mode: 0755
Expected owner: root
Expected group: bin
Expected file size (bytes): 1791664
Expected sum(1) of contents: 53780
Expected last modification: Nov 12 23:25:27 2007
Referenced by the following packages:
CSWvim
Current status: installed
3. pkgchk -ap /opt/csw/bin/vim – audits the permissions on the file ‘vim’ ( exit status 0/1 )
4. pkgchk -fp – fix permissions on the file
5. pkgchk -cp /opt/csw/bim/vim sum check ( integrity of the file )
6. pkgchk -q – returns useable exit status
### pkgadd ### install programs
1. pkgadd -d package_name – install from current directory or spool directory /var/spool/pkg
2. pkgadd – this will install programs in the spool directory
Common Solaris Package Online Repositories:
1. www.sunfreeware.com
2. www.blastwave.org – blastwave.org/mirrors.php
3. www.sun.com
pkgadd -d nano
pkgadd -v nano
pkgadd -d URL
Note: when installing via HTTP, packaged MUST be in package stream form.
Use ‘pkgtrans’ to transform packaged to packaged stream format.
### pkgrm ### Package Remove
1. pkgrm package_name