Routing Lab —Static route

por | 16 marzo, 2017

 

 

R1#show controller S0/0

Interface Serial0/0
Hardware is GT96K
DCE 530, clock rate 2000000
idb at 0x653ED468, driver data structure at 0x653F4B8C
wic_info 0x653F5190
Physical Port 1, SCC Num 1

R1#sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial0/0 unassigned YES unset administratively down down
FastEthernet0/1 unassigned YES unset administratively down down

R1(config)#interface s0/0
R1(config-if)#ip address 10.5.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#clock rate 64000

R1(config-if)#do sh ip int bri
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial0/0 10.5.2.1 YES manual up down
FastEthernet0/1 unassigned YES unset administratively down down

R2(config)#interface serial 0/0
R2(config-if)#ip address 10.5.2.2 255.255.255.0
R2(config-if)#no shutdown

R2(config-if)#do show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial0/0 10.5.2.2 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down

R1(config)#int fastEthernet 0/0
R1(config-if)#ip address 10.5.1.1 255.255.255.0

R2(config)#int fastEthernet 0/0
R2(config-if)#ip address 10.5.3.1 255.255.255.0

 

 

R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 2 subnets
C       10.5.3.0 is directly connected, FastEthernet0/0
C       10.5.2.0 is directly connected, Serial0/0

 

R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 2 subnets
C       10.5.2.0 is directly connected, Serial0/0
C       10.5.1.0 is directly connected, FastEthernet0/0

 

gns3@PC1:~$ sudo ifconfig eth0 10.5.1.50 netmask 255.255.255.0

gns3@PC1:~$ sudo route add default gw 10.5.1.1

gns3@PC2:~$ sudo ifconfig eth0 10.5.3.50 netmask 255.255.255.0
gns3@PC2:~$ sudo route add default gw 10.5.3.1

 

R1(config)#ip route 10.5.3.0 255.255.255.0 10.5.2.2

R1(config)#do show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 3 subnets
S       10.5.3.0 [1/0] via 10.5.2.2
C       10.5.2.0 is directly connected, Serial0/0
C       10.5.1.0 is directly connected, FastEthernet0/0

 

R1#ping 10.5.3.50

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.5.3.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/50/64 ms

 

R2(config)#ip route 10.5.1.0 255.255.255.0 10.5.2.1

 

R2(config)#do show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 3 subnets
C       10.5.3.0 is directly connected, FastEthernet0/0
C       10.5.2.0 is directly connected, Serial0/0
S       10.5.1.0 [1/0] via 10.5.2.1

 

**** Floating Static Route ****

R1(config)#int fa0/1
R1(config-if)#ip address 10.5.4.1 255.255.255.0
R1(config-if)#no shutdown

 

R2(config)#int fa0/1
R2(config-if)#ip address 10.5.4.2 255.255.255.0
R2(config-if)#no shutdown

Distance: 10
R1(config)#ip route 10.5.3.0 255.255.255.0 10.5.4.2 10

 

R1#show run | inc ip route
ip route 10.5.3.0 255.255.255.0 10.5.2.2
ip route 10.5.3.0 255.255.255.0 10.5.4.2 10

 

R2(config)#ip route 10.5.1.0 255.255.255.0 10.5.4.1 10

R2(config)#do show run | inc ip route
ip route 10.5.1.0 255.255.255.0 10.5.2.1
ip route 10.5.1.0 255.255.255.0 10.5.4.1 10
Shutdown serial:  (Simula que se fue la red serial)

R2(config)#int serial 0/0
R2(config-if)#shutdown

 

Aparece la ruta de backup ( ruta flotante)

R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 3 subnets
C       10.5.4.0 is directly connected, FastEthernet0/1
C       10.5.3.0 is directly connected, FastEthernet0/0
S       10.5.1.0 [10/0] via 10.5.4.1

 

Default Gateway Route

R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.254
R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.10.254